Item Outage - Delta eGift Card $10 & $25 - 4/21/2021

Incident Report for rewards

Resolved

This incident is now resolved. For more information regarding Delta $10 availability please go here:
https://rewardstatus.tangocard.com/incidents/pwnnpy4dm7sh
Posted May 03, 2021 - 16:27 PDT

Monitoring

Delta eGift Card $25 is now available again.

Delta eGift Card $10 remains inactive at the moment. We will provide updates as soon as we have more information to share.
Posted Apr 30, 2021 - 14:52 PDT

Investigating

We are currently investigating this issue.
Posted Apr 21, 2021 - 15:41 PDT

Identified

Delta eGift Card $10 & $25 are currently unavailable. We will post an update when these rewards are once again available.

The affected UTID is: U883236 & U116477
Posted Apr 21, 2021 - 15:41 PDT
This incident affected: Americas (USD).