Item Deprecation - Delta eGift Card $10
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jun 04, 2021 - 14:18 PDT
Identified
Effective immediately, Delta eGift Card $10 is no longer available through Tango Card.

The affected UTID is: U883236

Please make sure to remove this item from your catalog.
Posted May 03, 2021 - 16:24 PDT
This incident affected: Americas (USD).