Brand Outage - Jollydays Switzerland

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update: https://rewardstatus.tangocard.com/incidents/6m7jjm12f97z
Posted May 29, 2025 - 08:23 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U102040, U478097, and U143997
Posted May 21, 2025 - 10:37 PDT
This incident affected: Europe (CHF).