Brand Deprecation - Jollydays Switzerland

Incident Report for rewards

Resolved

This brand has been officially deprecated and is no longer available through Tango.
Posted Jun 24, 2025 - 10:49 PDT

Identified

Effective immediately, Jollydays Switzerland is no longer available through Tango.

The affected UTID(s) are: U102040, U478097, and U143997
Posted May 29, 2025 - 08:22 PDT
This incident affected: Europe (CHF).