Catalog Change Notice - TripGift® EUR

Incident Report for rewards

Resolved

This change is now live. The updated denomination range/ changes are reflected in the catalog.
Posted May 08, 2025 - 06:55 PDT

Identified

Effective immediately, TripGift EUR eGift Card has switched from a fixed item to variable denominations. The change is as follows:

No longer available:
U279732: €30
U365683: €100

New UTID and variable denominations:
U530721: Min €30.00 EUR - Max €5,000.00 EUR
Posted Apr 11, 2025 - 13:38 PDT
This incident affected: Europe (EUR (Belgium), EUR (Finland), EUR (France), EUR (Germany), EUR (Ireland), EUR (Italy), EUR (Netherlands), EUR (Spain), EUR (Austria)).