Item Denomination Change - Sephora eGift Cards
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jan 22, 2021 - 14:22 PST
Monitoring
Please note that Sephora eGift Card available maximum denomination has now been updated to $250 USD in our system.

The affected UTID is: U569822
Posted Dec 01, 2020 - 10:48 PST
Identified
Sephora eGift Cards is changing their maximum available denomination from $500 to $250 USD. The minimum remains the same at $5. This change to the maximum denomination will take effect on December 1st, 2020.

The affected UTID is: U569822
Posted Nov 19, 2020 - 15:19 PST
This incident affected: Americas (USD).