Brand Outage - Spotify IT Gift Card

Incident Report for rewards

Update

We are continuing to work on a fix for this issue.
Posted Mar 31, 2025 - 13:52 PDT

Identified

This brand is currently out of stock. We will post an update when it is available.

The affected UTIDs are: U286354, U057755, U129754
Posted Mar 28, 2025 - 08:53 PDT
This incident affects: Europe (EUR (Italy)).