Item Deprecation - Macy's E-Gift Card $500.00 - 1/20/2021
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Mar 05, 2021 - 16:22 PST
Identified
Effective today, January 20th, Macy's E-Gift Card $500.00 will no longer be available through Tango Card.

Affected UTID is: U769833

Please make sure to remove this items from your catalog.
Posted Jan 20, 2021 - 09:17 PST
This incident affected: Americas (USD).