Item Outage - IKEA Australia Gift Card $20 and $30

Incident Report for rewards

Resolved

These items are now back in stock and available for ordering.
Posted May 20, 2025 - 06:51 PDT

Identified

These items are currently out of stock. We will post an update when they are available.

The affected UTIDs are: U381689 and U572886
Posted May 19, 2025 - 07:26 PDT
This incident affected: Oceania (AUD).