Item Outage - PlayStation®Store Cartão Presente €50

Incident Report for rewards

Resolved

This item is no longer available.
Posted Feb 26, 2025 - 16:44 PST

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U416380
Posted Oct 05, 2023 - 16:38 PDT
This incident affected: Europe (EUR (Portugal)).