Item Outage - Argos eGift Card
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Oct 05, 2021 - 11:40 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 03, 2021 - 09:23 PDT
Identified
Argos eGift Card is currently unavailable. We will post an update when the outage is resolved.

The affected UTID is: U324815
Posted Aug 02, 2021 - 09:46 PDT
This incident affected: Europe (GBP).