Item Outage - IKEA Gift Card Turkey ₺100

Incident Report for rewards

Resolved

This item is now back in stock and available for ordering.
Posted May 09, 2025 - 06:38 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U912971
Posted May 08, 2025 - 06:57 PDT
This incident affected: Middle East (TRY).