Item Outage - PlayStation Store Gift Card UK £20 and £10

Incident Report for rewards

Resolved

These items are now back in stock and available for ordering.
Posted Apr 25, 2025 - 07:58 PDT

Identified

These items are currently out of stock. We will post an update when it is available.

The affected UTIDs are: U270877 and U124346
Posted Apr 24, 2025 - 14:01 PDT
This incident affected: Europe (GBP).