Brand Outage - Spotify eGift Card Poland

Incident Report for rewards

Update

We are continuing to work on a fix for this issue.
Posted Mar 31, 2025 - 07:47 PDT

Identified

This brand is currently out of stock. We will post an update when it is available.

The affected UTIDs are: U380824, U477928, U626626
Posted Mar 28, 2025 - 07:30 PDT
This incident affects: Europe (PLN).