Brand Outage - Bata India

Incident Report for rewards

Resolved

This brand is now back in stock and available for ordering.
Posted Jun 30, 2025 - 06:13 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U843018, U573114, U517676, U810720, U761894, and U513535
Posted Jun 26, 2025 - 10:34 PDT
This incident affected: Asia (INR).