Item Outage - Netflix E-Gift Card €‎25

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update:
https://rewardstatus.tangocard.com/incidents/r4fwl2ms30qk
Posted May 13, 2025 - 13:05 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U410276
Posted Apr 23, 2025 - 07:32 PDT
This incident affected: Europe (EUR (Lithuania)).