Item Outage - Non-MX Sales - Amazon.com.mx Gift Card $500 - 4/26/2021
Incident Report for rewards
Resolved
This outage has been resolved.
Posted Apr 26, 2021 - 10:53 PDT
Identified
Non-MX Sales - Amazon.com.mx Gift Card $500 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U791578
Posted Apr 26, 2021 - 09:02 PDT
This incident affected: Americas (MXN).