Item Outage - GrabFood Gift Card S$15
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Apr 26, 2021 - 17:05 PDT
Identified
GrabFood Gift Card S$15 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U296820
Posted Apr 20, 2021 - 09:38 PDT
This incident affected: Asia (SGD).