Increased Errors - Multiple Brands

Incident Report for rewards

Resolved

These brands are now back in stock and available for ordering.
Posted Mar 27, 2026 - 09:09 PDT

Investigating

We are experiencing an increase in errors with multiple brand orders. The issue is currently being investigated.

The affected brands are:

1-800-FLOWERS.COM®
Cheryl's Cookies
Harry & David
The Popcorn Factory
Posted Mar 26, 2026 - 11:46 PDT
This incident affected: Americas (USD).