Increased Errors - Physical Promotional Visa® Prepaid Card

Incident Report for rewards

Resolved

These items are now back in stock and available for ordering.
Posted Sep 09, 2025 - 14:42 PDT

Investigating

We are experiencing an increase in errors with Physical Promotional Visa® Prepaid Card orders. The issue is currently being investigated.

The affected UTID is:
U157316
U908695
U282331
Posted Sep 05, 2025 - 15:18 PDT
This incident affected: Americas (USD).