Item Outage - Falabella $40,000 Tarjeta de regalo electrónica
Incident Report for rewards
Update
We are continuing to work on a fix for this issue.
Posted Nov 13, 2024 - 13:45 PST
Identified
This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U469551
Posted Nov 13, 2024 - 13:43 PST
This incident affects: Americas (COP).