Increased Errors - Amazon European Brands

Incident Report for rewards

Update

We are continuing to investigate this issue.
Posted Feb 17, 2026 - 06:06 PST

Investigating

We are experiencing an increase in errors with Amazon European orders. The issue is currently being investigated.

The affected UTIDs are:
U191945
U493942
U080935
U173016
U000104
U752627
U165136
U156320
U001305
U913317
U172704
U697325
Posted Feb 17, 2026 - 06:04 PST
This incident affects: Europe (EUR (Belgium), EUR (Finland), EUR (France), EUR (Germany), EUR (Ireland), EUR (Italy), EUR (Netherlands), EUR (Portugal), EUR (Spain), GBP, PLN, SEK).