Inactive Item - Marionnaud Carte Cadeau €25
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jan 22, 2021 - 14:16 PST
Identified
Marionnaud Carte Cadeau €25 is currently unavailable and has been set to inactive in our system until further notice.

The affected UTID is:
U160363
Posted Dec 17, 2020 - 16:16 PST
This incident affected: Europe (EUR (France)).