Item Outage - Deliveroo IT Carta Regalo €25
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Oct 24, 2024 - 16:15 PDT
Identified
This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U875408
Posted Oct 03, 2024 - 10:47 PDT
This incident affected: Europe (EUR (Italy)).