Item Outage - Wayfair.com eGift Card $100.00
Incident Report for rewards
Resolved
This outage has been resolved.
Posted Jun 15, 2021 - 09:55 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 08, 2021 - 09:00 PDT
Identified
Wayfair.com eGift Card $100.00 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U681372
Posted Jun 08, 2021 - 08:33 PDT
This incident affected: Americas (USD).