Item Outage - Max Gift Card Oman 200﷼

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update: https://rewardstatus.tangocard.com/incidents/8xjd2pmnbj36
Posted May 07, 2025 - 08:05 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U509054
Posted Apr 28, 2025 - 10:33 PDT
This incident affected: Middle East (OMR).