Brand Outage - Soriana Mexico

Incident Report for rewards

Update

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U893140, U574266
Posted Jun 26, 2025 - 07:31 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U893140, U574266, & U442757
Posted Jun 26, 2025 - 07:12 PDT
This incident affects: Americas (MXN).