Item Outage - Daraz.Ik රු2000 Gift Card Sri Lanka

Incident Report for rewards

Update

We are continuing to work on a fix for this issue.
Posted Jul 11, 2025 - 08:34 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U058305
Posted Jun 30, 2025 - 13:22 PDT
This incident affects: Asia (LKR).