Increased Errors - Multiple PLN Brands

Incident Report for rewards

Resolved

These brands are now back in stock and available for ordering.
Posted Aug 13, 2026 - 10:16 PDT

Investigating

We are experiencing an increase in errors with multiple PLN brand orders. The issue is currently being investigated.

The affected brands are:

H&M Poland
Zalando Poland
Zabka All-Inclusive Poland
YES Poland
Ticketmaster Poland
Primark Poland
Orlen Poland
Mango Poland
Just Eat Poland
FlixBus Poland
Circle K No Fuel Poland
Circle K Poland
Posted Aug 07, 2026 - 10:40 PDT
This incident affected: Europe (PLN).