Item Deprecation - Sephora FR E-Gift Cards
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Apr 22, 2021 - 15:21 PDT
Identified
Effective March 31st, Sephora FR E-Gift Cards will no longer be available through Tango Card.

Affected UTIDs are: U106124, U861770, U492803

Please make sure to remove this item from your catalog.
Posted Mar 22, 2021 - 15:37 PDT
This incident affected: Europe (EUR (France)).