Item Outage - Sony PlayStation eGift Canada 40 CAD

Incident Report for rewards

Resolved

This denomination is no longer available from the brand and has been officially deprecated, and is no longer available through Tango.
Posted Dec 12, 2025 - 13:06 PST

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U260036
Posted Dec 08, 2025 - 09:42 PST
This incident affected: Americas (CAD).