Item Deprecation - Seamless Gift Card
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Nov 05, 2021 - 14:25 PDT
Update
Effective immediately, this Seamless is no longer available through Tango Card.
Posted Jul 22, 2021 - 15:05 PDT
Identified
Seamless Gift Card is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U596020
Posted Jul 21, 2021 - 13:34 PDT
This incident affected: Americas (USD).