Item Outage - App Store & iTunes Germany Gift Card €25 - 1/12/2021
Incident Report for rewards
Resolved
This outage has been resolved.
Posted Jan 12, 2021 - 09:01 PST
Identified
App Store & iTunes Germany Gift Card €25 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U036202
Posted Jan 12, 2021 - 08:53 PST
This incident affected: Europe (EUR (Germany)).