Brand Outage - Wolt Gift Cards

Incident Report for rewards

Resolved

The following unavailable items (Wolt Estonia, Greece, Malta) are no longer available and the incident has been closed. Here's the link to the most recent status update: https://rewardstatus.tangocard.com/incidents/z8vw4lk7qqhp
Posted May 18, 2026 - 10:10 PDT

Update

The following Wolt items are available for order now:

Wolt Slovenia: U893923, U588252
Wolt Lithuania: U502077, U095503
Wolt Croatia: U614673, U468890
Wolt Cyprus: U450283, U097036

The following items are still unavailable:

Wolt Estonia: U670400, U377104
Wolt Malta: U701695, U065663
Wolt Greece: U587916, U498431
Posted Mar 26, 2026 - 14:53 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are:

Wolt Greece: U587916, U498431
Wolt Slovenia: U893923, U588252
Wolt Lithuania: U502077, U095503
Wolt Croatia: U614673, U468890
Wolt Estonia: U670400, U377104
Wolt Malta: U701695, U065663
Wolt Cyprus: U450283, U097036
Posted Feb 03, 2026 - 14:53 PST
This incident affected: Europe (EUR (Slovenia), EUR (Greece), EUR (Croatia), EUR (Estonia), EUR (Lithuania), EUR (Malta)).