Inactive Item - Delta eGift Card
Incident Report for rewards
Resolved
Delta eGift cards are active and available, again.
Posted Jan 20, 2021 - 13:07 PST
Identified
Delta eGift Cards are currently unavailable. We will post an update when this reward is once again available.

The affected UTID are:
U883236
U636802
U116477
U069792
U438511
U828691
Posted Jan 20, 2021 - 10:15 PST
This incident affected: Americas (USD).