Item Outage - Apple Switzerland eGift
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 14:15 PDT
Identified
This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U316275
Posted Apr 12, 2024 - 13:37 PDT
This incident affected: Europe (CHF).