Brand Outage - CDON.COM Sweden

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update:
https://rewardstatus.tangocard.com/incidents/8dy4bl4w2g09
Posted Aug 04, 2025 - 14:03 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U729165, U643964, U858522, U515698, U703631, U517868, U934962
Posted Jul 30, 2025 - 08:23 PDT
This incident affected: Europe (SEK).