Item Outage - Amazon.es Gift Certificate Portugal

Incident Report for rewards

Resolved

This item is now back in stock and available for ordering.
Posted Apr 22, 2025 - 08:53 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTIDs are: U830396 and U533462
Posted Apr 21, 2025 - 06:22 PDT
This incident affected: Europe (EUR (Portugal)).