Item Outage - zooplus.de Gift Card €25 and €5

Incident Report for rewards

Resolved

These items are no longer available and the incident has been closed.

Here's the link to the most recent status update: https://rewardstatus.tangocard.com/incidents/hvrw0hf7d9lc
Posted Apr 25, 2025 - 12:43 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTIDs are: U855195 and U418580
Posted Apr 03, 2025 - 09:06 PDT
This incident affected: Europe (EUR (Germany)).