Brand Outage - Starbucks Hungary

Incident Report for rewards

Resolved

This brand is no longer available and the incident has been closed. Here's the link to the most recent status update:
https://rewardstatus.tangocard.com/incidents/zhv9hr8cr7v3
Posted Jan 14, 2026 - 11:09 PST

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U917770 and U416952
Posted Sep 19, 2025 - 06:17 PDT
This incident affected: Europe (HUF).