Item Outage - Zappos.com e-Gift Card $25, $50, $100

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 14:28 PDT

Investigating

These items are currently out of stock. We will post an update when they are available.

The affected UTID is:
U635570
U871734
U382256
Posted Aug 07, 2025 - 16:57 PDT
This incident affected: Americas (USD).