Item Outage - Netflix €25 eGift Card

Incident Report for rewards

Resolved

This item is no longer available and the incident has been closed. Here's the link to the most recent status update:
https://rewardstatus.tangocard.com/incidents/zjy9n9tdszsx
Posted May 13, 2025 - 13:07 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U276218
Posted Apr 16, 2025 - 13:31 PDT
This incident affected: Europe (EUR (Latvia)).