Item Outage - Amazon India

Incident Report for rewards

Resolved

This brand is now back in stock and available for ordering.
Posted Sep 09, 2026 - 11:14 PDT

Identified

These items are currently out of stock. We will post an update when they are available.

The affected UTIDs are:
U128141
U738315
U883093
U705529
U165089
U884558
U840890
U574083
U481200
U478645
Posted Sep 07, 2026 - 03:37 PDT
This incident affected: Asia (INR).