Item Deprecation - Kigso Games Gift Card $10

Incident Report for rewards

Update

Effective immediately, Kigso Games $10 is no longer available through Tango.

The affected UTID(s) are: U994379
Posted Feb 25, 2025 - 13:16 PST

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U994379
Posted Feb 24, 2025 - 06:46 PST
This incident affects: Americas (USD).