Item Deprecation - Vale Presente Shoptime Virtual $R20
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 10:49 PDT
Identified
Effective immediately, [item] is no longer available through Tango.

The affected UTID(s) are: U137173
Posted Aug 27, 2024 - 06:27 PDT
This incident affected: Americas (BRL).