Brand Outage -Colruyt Belgium

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Feb 16, 2025 - 13:42 PST

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U072595, U412288, U093360, & U559015
Posted Feb 13, 2025 - 13:32 PST
This incident affected: Europe (EUR (Belgium)).