Item Outage - Flipkart Gift Card ₹50
Incident Report for rewards
Resolved
This incident has been resolved.
Posted May 01, 2024 - 14:44 PDT
Identified
This item is currently out of stock. We will post an update when it is available.

The affected UTID is:
U201473
Posted Apr 26, 2024 - 15:00 PDT
This incident affected: Asia (INR).