Brand Deprecation - Plantagen Finland

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 11:10 PST

Identified

Effective immediately, Plantagen Finland is no longer available through Tango.

The affected UTID(s) are: U815087,U651489, U287953, & U309356
Posted Jan 22, 2025 - 11:23 PST
This incident affected: Europe (EUR (Finland)).