Brand Outage - Playstation Store South Africa

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 11:42 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U308253, U865936, U658829, & U889416
Posted Mar 14, 2025 - 07:20 PDT
This incident affected: Africa (ZAR).