Item Outage - Steam Wallet Code €20
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 10:02 PDT
Identified
This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U128267
Posted Jan 16, 2024 - 15:30 PST
This incident affected: Europe (EUR (Belgium), EUR (Finland), EUR (France), EUR (Germany), EUR (Ireland), EUR (Italy), EUR (Netherlands), EUR (Portugal), EUR (Spain), EUR (Austria), EUR (Slovakia), EUR (Slovenia), EUR (Greece), EUR (Latvia), EUR (Croatia), EUR (Montenegro), EUR (Estonia), EUR (Lithuania)).